What’s Vulnerable › Vulnerabilities
CVE-2026-96641: Pillow: Reachable undefined behavior in native integer operations, potentially leading to denial of service or logic integrity compromise
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-190
Description
Pillow is a Python imaging library. Prior to 13.0.0, PILfont text-width accumulation in src/_imaging.c checks positive glyph advances against INT_MAX but does not check negative advances against INT_MIN. Repeating a signed 16-bit advance of -32768 can therefore execute a signed C integer overflow in xsize += dx, producing a large positive width from a negative mathematical result. Applications that use getlength(), getsize(), or derived layout, quota, serialization, or allocation calculations can experience logic-integrity errors or resource consumption, while the high-level mask path commonly retains a decompression-bomb check. This issue is fixed in version 13.0.0.
Affected products
- python-pillow Pillow: before 13.0.0 — fixed in 13.0.0
- Pypi Pillow: before 13.0.0; 1.0, 1.1, 1.2, 1.3, 1.4, 1.5 (+101) — fixed in 13.0.0
- python-pillow Pillow: before 13.0.0
How to fix
Upgrade to a fixed version: python-pillow Pillow 13.0.0; Pypi Pillow 13.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/python-pillow/Pillow/commit/80de4be9e38d3a6148dd4d8491eb80cd12b760a4
- https://github.com/python-pillow/Pillow/pull/10010
- https://github.com/python-pillow/Pillow/releases/tag/13.0.0
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-4rm8-3hmm-39fg
Get alerted when CVE-2026-96641 or the next vulnerability affects your stack