What’s Vulnerable › Vulnerabilities
CVE-2026-96754: orval @orval/hono before 8.29.0 Code Injection via OpenAPI Path
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-29
- Weakness: CWE-94
Description
orval versions before 8.29.0 contain a code injection vulnerability in the @orval/hono generator that fails to escape OpenAPI path values in single-quoted route literals. Attackers can craft an OpenAPI document with an apostrophe in a static path segment to inject arbitrary JavaScript code that executes when the generated TypeScript module is imported.
Affected products
- orval-labs orval: before 8.29.0 — fixed in 8.29.0
How to fix
Upgrade to a fixed version: orval-labs orval 8.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/orval-labs/orval
- https://github.com/orval-labs/orval/blob/v8.28.1/packages/hono/src/index.ts#L169-L175
- https://github.com/orval-labs/orval/commit/155a5b7a38ff6886020cbc4c292db57c2793e6b6
- https://github.com/orval-labs/orval/commit/d346d94a660e50a2f8d0f7c17fee2c4c69d8dc23
- https://github.com/orval-labs/orval/pull/4006
- https://github.com/orval-labs/orval/security/advisories/GHSA-g4mf-q5hw-f9j9
- https://www.vulncheck.com/advisories/orval-orval-hono-before-8.29.0-code-injection-via-openapi-path
- https://github.com/orval-labs/orval/security/advisories/GHSA-g4mf-q5hw-f9j9
Get alerted when CVE-2026-96754 or the next vulnerability affects your stack