What’s Vulnerable › Vulnerabilities
CVE-2026-96755: orval @orval/effect 8.14.0 through 8.28.1 Code Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-94
Description
orval versions 8.14.0 through 8.28.1 contain a code injection vulnerability in the @orval/effect generator that converts OpenAPI schema defaults into template literals. Attackers can inject arbitrary JavaScript expressions via schema defaults containing ${...} syntax, which are executed at module scope when the generated code is built or imported.
Affected products
- orval-labs orval: from 8.14.0 before 8.29.0 — fixed in 8.29.0
How to fix
Upgrade to a fixed version: orval-labs orval 8.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/orval-labs/orval
- https://github.com/orval-labs/orval/blob/v8.28.1/packages/effect/src/index.ts#L298-L302
- https://github.com/orval-labs/orval/commit/d346d94a660e50a2f8d0f7c17fee2c4c69d8dc23
- https://github.com/orval-labs/orval/pull/3995
- https://github.com/orval-labs/orval/security/advisories/GHSA-q7f2-jg6j-r867
- https://www.vulncheck.com/advisories/orval-orval-effect-8.14.0-through-8.28.1-code-injection
- https://github.com/orval-labs/orval/security/advisories/GHSA-q7f2-jg6j-r867
Get alerted when CVE-2026-96755 or the next vulnerability affects your stack