What’s Vulnerable › Vulnerabilities
CVE-2026-96757: orval before 8.29.0 Code Injection via unescaped OpenAPI media-type
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-94
Description
orval before 8.29.0 fails to escape OpenAPI media-type keys when emitting them into single-quoted Content-Type string literals in generated code. Attackers can inject JavaScript through crafted media-type keys in OpenAPI specifications that executes when generated fetch operations or mock resolvers are invoked.
Affected products
- orval-labs orval: from 6.7.1 before 8.29.0 — fixed in 8.29.0
How to fix
Upgrade to a fixed version: orval-labs orval 8.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/orval-labs/orval
- https://github.com/orval-labs/orval/blob/v8.28.1/packages/fetch/src/index.ts#L584
- https://github.com/orval-labs/orval/commit/43af282d62dca0ef3140023741fb768f6a718adb
- https://github.com/orval-labs/orval/commit/a2d4af59f3b167dc8a7a65d15f51cdb89ebe2fe5
- https://github.com/orval-labs/orval/pull/4007
- https://github.com/orval-labs/orval/security/advisories/GHSA-4q3x-rqfw-3x8p
- https://github.com/orval-labs/orval/security/advisories/GHSA-rcpr-mq4m-jx9j
- https://www.vulncheck.com/advisories/orval-before-8.29.0-code-injection-via-unescaped-openapi-media-type
- https://github.com/orval-labs/orval/security/advisories/GHSA-4q3x-rqfw-3x8p
Get alerted when CVE-2026-96757 or the next vulnerability affects your stack