What’s Vulnerable › Vulnerabilities
CVE-2026-96804: CVE-2026-96804
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-24
- Weakness: CWE-502
Description
MLflow's statsmodel flavor, versions 2.1.0 to 3.14.0, omits the MLFLOW_ALLOW_PICKLE_DESERIALIZATION=False security control entirely in _load_model(), which allows a remote attacker to execute arbitrary code via a crafted MLmodel artifact.
Affected products
- mlflow/mlflow: from 2.1 before 3.15.0 — fixed in 3.15.0
How to fix
Upgrade to a fixed version: mlflow/mlflow 3.15.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-96804 or the next vulnerability affects your stack