What’s Vulnerable › Vulnerabilities
CVE-2026-96807
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-26
- Weakness: CWE-61
Description
In Flatpak before 1.18.1, a malicious sandboxed app can replace ~/.var/app/$appid/.ld.so with a symlink, causing regenerate_ld_cache to write files at an arbitrary location. The filenames and content are not attacker controlled, making this hard to exploit.
Affected products
- flatpak: before 1.18.1 — fixed in 1.18.1
How to fix
Upgrade to a fixed version: flatpak 1.18.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-96807 or the next vulnerability affects your stack