What’s Vulnerable › Vulnerabilities
CVE-2026-96872: WikiLambda public function execution bypasses the unsaved-code permission through nested Z825 compositions
- Severity: low (CVSS 2.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-24
- Weakness: CWE-280
Description
Improper handling of insufficient permissions or privileges vulnerability in The Wikimedia Foundation Mediawiki - WikiLambda Extension on Linux, MacOS, and Windows allows Accessing Functionality Not Properly Constrained by ACLs. This issue affects Mediawiki - WikiLambda Extension: before 1.47.0.
Affected products
- Wikimedia Foundation MediaWiki: before 1.47.0 — fixed in 1.47.0
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.47.0. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikiLambda/+/1326392
- https://phabricator.wikimedia.org/T435085
Get alerted when CVE-2026-96872 or the next vulnerability affects your stack