What’s Vulnerable › Vulnerabilities
CVE-2026-96883: Type confusion in AWS pgcollection allows remote code execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-25
- Weakness: CWE-843
Description
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.
Affected products
- AWS pgcollection: from 2.0.0 through 2.1.1
References
- https://aws.amazon.com/security/security-bulletins/2026-118-aws/
- https://github.com/aws/pgcollection/releases/tag/v2.1.2
- https://github.com/aws/pgcollection/security/advisories/GHSA-g539-cj32-hv6r
Get alerted when CVE-2026-96883 or the next vulnerability affects your stack