What’s Vulnerable › Vulnerabilities
CVE-2026-96890: Server-Side Request Forgery vulnerability was identified in GitHub Enterprise Server that allowed requests to attacker-controlled internal hosts
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-09
- Weakness: CWE-918
Description
A Server-Side Request Forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed a repository contributor to cause the appliance to issue requests to attacker-controlled internal hosts, which could be chained to achieve remote code execution on the appliance. The secret scanning validator for GCP service account credentials trusted the token endpoint embedded in a committed credential and issued a request to it without restricting the destination. Exploitation required an authenticated user with permission to push to a repository on an instance with GitHub Advanced Security and secret scanning validity checks enabled, a non-default configuration. This vulnerability affected GitHub Enterprise Server 3.20, 3.21, and 3.22 and was fixed in versions 3.20.9, 3.21.7, and 3.22.2. This vulnerability was reported through the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: from 3.20.0 before 3.20.9; from 3.21.0 before 3.21.7; from 3.22.0 before 3.22.2 — fixed in 3.20.9, 3.21.7, 3.22.2
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.20.9, 3.21.7, 3.22.2. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.9
- https://docs.github.com/en/enterprise-server@3.21/admin/release-notes#3.21.7
- https://docs.github.com/en/enterprise-server@3.22/admin/release-notes#3.22.2
Get alerted when CVE-2026-96890 or the next vulnerability affects your stack