What’s Vulnerable › Vulnerabilities
CVE-2026-96893: Improper Neutralization of Input Used for LLM Prompting in GitLab
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-14
- Weakness: CWE-74
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to inject specially crafted content into AI agent instructions, potentially causing unintended command execution attributed to other users, due to improper neutralization of special elements in AI conversation context construction.
Affected products
- GitLab: from 19.1.0 before 19.2.8; from 19.3.0 before 19.3.5; from 19.4.0 before 19.4.2 — fixed in 19.2.8, 19.3.5, 19.4.2
How to fix
Upgrade to a fixed version: GitLab 19.2.8, 19.3.5, 19.4.2. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/607968
Get alerted when CVE-2026-96893 or the next vulnerability affects your stack