What’s Vulnerable › Vulnerabilities
CVE-2026-96895: WP YouTube Lyte < 1.7.31 - Contributor+ Stored XSS via Embed Block Attributes
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-28
- Weakness: CWE-79
Description
The WP YouTube Lyte WordPress plugin before 1.7.31 does not escape some attributes of YouTube embed blocks before outputting them in an HTML attribute when rendering the block, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks.
Affected products
- WP YouTube Lyte: before 1.7.31 — fixed in 1.7.31
How to fix
Upgrade to a fixed version: WP YouTube Lyte 1.7.31. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-96895 or the next vulnerability affects your stack