What’s Vulnerable › Vulnerabilities
CVE-2026-9698: DBI versions before 1.648 for Perl saved errors in a limited-sized buffer
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-09-03
- Weakness: CWE-787
Description
DBI versions before 1.648 for Perl saved errors in a limited-sized buffer. Error messages that were returned when RaiseError, PrintError or HandleError were set were written to a 200-byte buffer without a length limit. Attackers that can influence the error text in an application can trigger a buffer overflow.
Affected products
- HMBRAND DBI: before 1.648 — fixed in 1.648
How to fix
Upgrade to a fixed version: HMBRAND DBI 1.648. Check the vendor advisory for mitigations.
References
- https://github.com/perl5-dbi/dbi/commit/bfe5d73c162d2d1f761a639a0aa33aad6a9eb54e.patch
- https://metacpan.org/release/HMBRAND/DBI-1.648/changes
- http://www.openwall.com/lists/oss-security/2026/06/09/9
- https://access.redhat.com/errata/RHSA-2026:38512
- https://access.redhat.com/errata/RHSA-2026:38513
- https://access.redhat.com/errata/RHSA-2026:38901
- https://access.redhat.com/errata/RHSA-2026:53371
- https://access.redhat.com/errata/RHSA-2026:62667
- https://access.redhat.com/security/cve/CVE-2026-9698
- https://bugzilla.redhat.com/show_bug.cgi?id=2486734
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-9698.json
Get alerted when CVE-2026-9698 or the next vulnerability affects your stack