What’s Vulnerable › Vulnerabilities
CVE-2026-97056: SigNoz before 0.143.0 Insufficient Session Expiration Authentication Bypass
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-24
- Weakness: CWE-613
Description
SigNoz versions from v0.98.0 up to (but not including) v0.143.0, when configured to use the opaque session tokenizer (which was not the default before v0.143.0), do not revoke a user's existing login sessions when the user's password is reset with a reset token (UpdatePasswordByResetPasswordToken, reachable via POST /api/v2/factor_password/reset) or when the user is deleted (DeleteUser, reachable via DELETE /api/v2/users/{id}). Neither code path calls the tokenizer's DeleteTokensByUserID, so cached tokens and identities are left in place. An attacker who already holds a session token for the account — for example from a stolen browser session or from a user being offboarded — retains the account's full access, up to administrator, after a password reset until the token reaches its configured maximum lifetime (30 days by default), and after user deletion until the token next rotates (30 minutes by default). This defeats password reset and user deletion as a means of terminating access. The issue is fixed in v0.143.0.
Affected products
- signoz: from 0.98.0 before 0.143.0 — fixed in 0.143.0
How to fix
Upgrade to a fixed version: signoz 0.143.0. Check the vendor advisory for mitigations.
References
- https://github.com/SigNoz/signoz/commit/b02aae2db3
- https://github.com/SigNoz/signoz/commit/c122bc09b4
- https://github.com/SigNoz/signoz/commit/e2e9173986
- https://github.com/SigNoz/signoz/commit/faaed20dbd
- https://github.com/SigNoz/signoz/security/advisories/GHSA-xrgp-3fq4-xg83
- https://www.vulncheck.com/advisories/signoz-before-0.143.0-insufficient-session-expiration-authentication-bypass
- https://github.com/SigNoz/signoz/security/advisories/GHSA-xrgp-3fq4-xg83
Get alerted when CVE-2026-97056 or the next vulnerability affects your stack