What’s Vulnerable › Vulnerabilities
CVE-2026-9709: Themeco Cornerstone < 7.8.9 (Premium, bundled with X Theme) - Subscriber+ Arbitrary User Meta Disclosure
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-06-25
Description
The Cornerstone WordPress plugin before 7.8.9 does not enforce capability checks on one of its REST API routes, allowing any authenticated user to disclose the metadata of any other user, including roles, session token previews and stored billing/shipping fields. This affects the premium co Cornerstone page builder distributed bundled with the X , not the unrelated free `cornerstone` Cornerstone WordPress plugin before 7.8.9 (v0.8.x) on the .org repository.
Affected products
- Cornerstone: from 3.0.0 before 7.8.9 — fixed in 7.8.9
How to fix
Upgrade to a fixed version: Cornerstone 7.8.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3ade0e4e-2070-4d3b-8f31-0d446839efd0/
- https://wpscan.com/vulnerability/3ade0e4e-2070-4d3b-8f31-0d446839efd0/
Get alerted when CVE-2026-9709 or the next vulnerability affects your stack