What’s Vulnerable › Vulnerabilities
CVE-2026-97152
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-24
- Weakness: CWE-122
Description
Nanomsg versions 0.5-beta through 1.x before 1.2.3 has a remotely exploitable buffer overflow in the WebSocket transport, due to an unchecked copy of the Sec-WebSocket-Version header, through snprintf.
Affected products
- Nanomsg: from 0.5.0 before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: Nanomsg 1.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/nanomsg/nanomsg/pull/1130
- https://github.com/nanomsg/nanomsg/releases/tag/1.2.3
- https://nanomsg.org
Get alerted when CVE-2026-97152 or the next vulnerability affects your stack