What’s Vulnerable › Vulnerabilities
CVE-2026-97188: String Locator < 2.6.8 - Unauthenticated PHP Object Injection via Database Editor
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-07
- Weakness: CWE-502
Description
The String locator WordPress plugin before 2.6.8 does not restrict the classes allowed when deserializing the content of a database row saved through its database editor, allowing unauthenticated attackers to store a serialized PHP object that is instantiated when an administrator later opens and saves that row. If a suitable POP chain is present via another installed String locator WordPress plugin before 2.6.8 or , this can lead to arbitrary file deletion, sensitive data disclosure or remote code execution.
Affected products
- String locator: before 2.6.8 — fixed in 2.6.8
How to fix
Upgrade to a fixed version: String locator 2.6.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-97188 or the next vulnerability affects your stack