What’s Vulnerable › Vulnerabilities
CVE-2026-97205: NGINX ngx_http_core_module vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-416
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_core_module module. When asynchronous file I/O (AIO) is enabled in certain configurations, processing a Server Side Includes (SSI) page containing “include virtual” commands may trigger a Use-After-Free (UAF) in the NGINX worker process. This may cause memory corruption or a worker process crash. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system, corrupt its memory, or possibly trigger code execution. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Open Source: from 1.31.0 before 1.31.7; from 1.30.0 before 1.30.6 — fixed in 1.30.6, 1.31.7
- F5 NGINX Plus: from 37.1.0 before 37.1.0.1; from 37.0.0 before 37.0.5.1; from R36; from R35; from R34; from R33 — fixed in 37.0.5.1, 37.1.0.1
How to fix
Upgrade to a fixed version: F5 NGINX Open Source 1.30.6, 1.31.7; F5 NGINX Plus 37.0.5.1, 37.1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-97205 or the next vulnerability affects your stack