What’s Vulnerable › Vulnerabilities
CVE-2026-97227: NextScripts: Social Networks Auto-Poster < 4.4.8 - Authenticated Social Account Credential Disclosure and Data Deletion
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-28
- Weakness: CWE-862
Description
The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8 does not perform capability or ownership checks on several of its AJAX actions, relying on a nonce alone, allowing users an administrator has granted access to its posting features to export the site's configured social account credentials, delete arbitrary posts and reset the NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8's configuration.
Affected products
- NextScripts: Social Networks Auto-Poster: before 4.4.8 — fixed in 4.4.8
How to fix
Upgrade to a fixed version: NextScripts: Social Networks Auto-Poster 4.4.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-97227 or the next vulnerability affects your stack