What’s Vulnerable › Vulnerabilities
CVE-2026-97380: MariaDB: GRANT PROXY with empty password incorrectly checks grantor's privileges
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-28
- Weakness: CWE-620
Description
MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the GRANT PROXY statement treats an IDENTIFIED clause with an empty password as though authentication were not specified, causing it to check the wrong grantor privileges. A low-privileged attacker who can name another account can exploit this authorization error to set that account's password. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
Affected products
- MariaDB: from 10.6.1 before 10.6.28; from 10.11.1 before 10.11.19; from 11.4.1 before 11.4.13; from 11.8.1 before 11.8.9; from 12.3.1 before 12.3.3; 13.0.1 (and their updates) — fixed in 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3
- MariaDB server: from 10.6.1, < 10.6.28; from 10.11.1, < 10.11.19; from 11.4.1, < 11.4.13; from 11.8.1, < 11.8.9; from 12.3.1, < 12.3.3; from 13.0.1, < 13.0.2
How to fix
Upgrade to a fixed version: MariaDB 10.6.28, 10.11.19, 11.4.13, 11.8.9. Check the vendor advisory for mitigations.
References
- https://github.com/MariaDB/server/commit/dbd60d0ad8daa2d01050346aa50b7b102490e456
- https://github.com/MariaDB/server/releases/tag/mariadb-10.11.19
- https://github.com/MariaDB/server/releases/tag/mariadb-10.6.28
- https://github.com/MariaDB/server/releases/tag/mariadb-11.4.13
- https://github.com/MariaDB/server/releases/tag/mariadb-11.8.9
- https://github.com/MariaDB/server/releases/tag/mariadb-12.3.3
- https://github.com/MariaDB/server/releases/tag/mariadb-13.0.2
- https://github.com/MariaDB/server/security/advisories/GHSA-625w-4hgq-qwmr
- https://jira.mariadb.org/browse/MDEV-40470
Get alerted when CVE-2026-97380 or the next vulnerability affects your stack