What’s Vulnerable › Vulnerabilities
CVE-2026-9742: Authenticate command with specific mechanism parameter can trigger server crash
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-1287
Description
When OIDC authentication is enabled in configuration, clients may set specific values in the "mechanism" parameter of the "authenticate" command that lead to server crash. The authenticate command is accessible to unauthenticated clients, leading to pre-auth denial-of-service in affected product configurations.
Affected products
- MongoDB: from 8.2.0 before 8.2.10; from 8.3.0 before 8.3.3 — fixed in 8.2.10, 8.3.3
How to fix
Upgrade to a fixed version: MongoDB 8.2.10, 8.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9742 or the next vulnerability affects your stack