What’s Vulnerable › Vulnerabilities
CVE-2026-97421: RDMA/umem: Be careful about boundary conditions in ib_umem_find_best_pgsz()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-10-03
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/umem: Be careful about boundary conditions in ib_umem_find_best_pgsz() Several corner cases, especially important on 32 bits: - umem->iova is u64, the function argument should pass in u64 or iova will be truncated - Check that the length is not too large for the iova - Check that lengths > 4G don't overflow the GENMASK
Affected products
- Linux kernel: from 5.4.73 before 5.5; from 5.8.17 before 5.9; from 5.9.2 before 5.10; 5.10 — fixed in 5.10, 5.5, 5.9, 7.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10, 5.5, 5.9, 7.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/09ea6837a0434fb4db99528a5055b6d822135dcf
- https://git.kernel.org/stable/c/3014da7587ce006cd08004fd6b257626b314e0a3
- https://git.kernel.org/stable/c/5fc5b73109540809b094710fac44da81dd8a3ff8
- https://git.kernel.org/stable/c/ae3cf7d2c4d506c5c91746321644e1a08d989e2a
- https://git.kernel.org/stable/c/ddccf6cc3861de2fe60986933bead79220e0d797
- https://git.kernel.org/stable/c/e9bbb5f5349ef560ff6f0395564f04c3aa664559
Get alerted when CVE-2026-97421 or the next vulnerability affects your stack