What’s Vulnerable › Vulnerabilities
CVE-2026-9749: Using MaxKey() may crash the server
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-617
Description
This issue can occur when running an aggregation pipeline that uses the internal $exchange stage configured with key-range partitioning and order-preserving delivery. If a single key range produces enough documents to fill its exchange buffer (that is, many results are routed to the same consumer), the server reaches the code path where a full per-consumer buffer is detected but the internal "high watermark" for that key range is not updated as intended.
Affected products
- MongoDB: from 7.0.0 before 7.0.35; from 8.0.0 before 8.0.24; from 8.2.0 before 8.2.10; from 8.3.0 before 8.3.3 — fixed in 7.0.35, 8.0.24, 8.2.10, 8.3.3
How to fix
Upgrade to a fixed version: MongoDB 7.0.35, 8.0.24, 8.2.10, 8.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9749 or the next vulnerability affects your stack