What’s Vulnerable › Vulnerabilities
CVE-2026-9754: Stack memory disclosure in filemd5 command
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-457
Description
An authenticated user with the read role may read limited amounts of uninitialized stack memory via specially-crafted issuances of the filemd5 command
Affected products
- MongoDB: from 8.2.0 before 8.2.10; from 8.3.0 before 8.3.3 — fixed in 8.2.10, 8.3.3
How to fix
Upgrade to a fixed version: MongoDB 8.2.10, 8.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9754 or the next vulnerability affects your stack