What’s Vulnerable › Vulnerabilities
CVE-2026-9762: IBM® Data Server driver for JDBC and SQLJ is vulnerable to remote code execution when jdbc url is under user control
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-94
Description
IBM Db2 11.5.0 through 11.5.9, and 12.1.0 through 12.1.4 is vulnerable to remote code execution when jdbc url is under user control.
Affected products
- IBM Db2 for Linux, UNIX and Windows: from 11.5.0 through 11.5.9; from 12.1.0 before 12.1.5 — fixed in 12.1.5
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 12.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9762 or the next vulnerability affects your stack