What’s Vulnerable › Vulnerabilities
CVE-2026-97629: NGINX ngx_http_ssl_module vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-29
- Weakness: CWE-908
Description
Description When NGINX Plus or NGINX Open Source is configured with ssl_session_cache shared:name:size without an explicit ssl_session_ticket_key file directives to automatically rotate SSL session ticket keys, a remote unauthenticated attacker is able to forge client SSL sessions in a non-deterministic manner that is beyond the attacker's control. An attacker could leverage this vulnerability to bypass verification of client certificates. Impact This vulnerability can lead to the exposure of resources or functionality to unintended actors, possibly providing attackers with access to sensitive information. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Open Source: from 1.31.0 before 1.31.7; from 1.30.0 before 1.30.6; from 1.23.3 — fixed in 1.31.7, 1.30.6
- F5 NGINX Plus: from 37.1.0 before 37.1.0.1; from 37.0.0 before 37.0.5.1; from R36; from R35; from R34; from R33 — fixed in 37.1.0.1, 37.0.5.1
How to fix
Upgrade to a fixed version: F5 NGINX Open Source 1.31.7, 1.30.6; F5 NGINX Plus 37.1.0.1, 37.0.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-97629 or the next vulnerability affects your stack