What’s Vulnerable › Vulnerabilities
CVE-2026-9769: justhtml before 1.10.0 Denial of Service via deeply nested HTML
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-23 · updated 2026-10-12
- Weakness: CWE-674
Description
justhtml through 1.9.1 (fixed in 1.10.0) is vulnerable to uncontrolled recursion leading to denial of service. During JustHTML() construction, TreeBuilder.finish() unconditionally calls _populate_selectedcontent(), which recursively traverses the DOM tree via _find_elements()/_find_element() without a depth bound. An attacker who can supply HTML for parsing can provide deeply nested elements (e.g., ~1000 nested <div> tags, roughly 11 KB) to exceed CPython's default recursion limit and trigger an unhandled RecursionError, which may abort parsing, fail requests, or terminate a worker/process depending on the host application's exception handling.
Affected products
- EmilStenstrom justhtml: before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: EmilStenstrom justhtml 1.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/EmilStenstrom/justhtml/security/advisories/GHSA-v7cf-c9rm-wm3j
- https://www.vulncheck.com/advisories/justhtml-before-denial-of-service-via-deeply-nested-html
- https://github.com/EmilStenstrom/justhtml/security/advisories/GHSA-v7cf-c9rm-wm3j
Get alerted when CVE-2026-9769 or the next vulnerability affects your stack