What’s Vulnerable › Vulnerabilities
CVE-2026-9772: Unraid Web Server FileUpload Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-06-26
- Weakness: CWE-78
Description
Unraid Web Server FileUpload Command Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Unraid. Authentication is required to exploit this vulnerability. The specific flaw exists within FileUpload.php. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of the www-data user. Was ZDI-CAN-30116.
Affected products
- Unraid: before 7.3.0 — fixed in 7.3.0
How to fix
Upgrade to a fixed version: Unraid 7.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9772 or the next vulnerability affects your stack