What’s Vulnerable › Vulnerabilities
CVE-2026-97723
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-09-30
- Weakness: CWE-79
Description
madpsy ka9q_ubersdr before 0.1.58 has a stored cross-site scripting (XSS) vulnerability in the chat message rendering functionality. User-controlled URLs in chat messages were insufficiently neutralized before being converted into HTML links. Quotation characters could break out of the generated href attribute and introduce attacker-controlled HTML attributes, allowing arbitrary JavaScript to execute in the browser of another user when the stored chat message was rendered. No click on the malicious link was required.
Affected products
- madpsy ka9q_ubersdr: before 0.1.58 — fixed in 0.1.58
How to fix
Upgrade to a fixed version: madpsy ka9q_ubersdr 0.1.58. Check the vendor advisory for mitigations.
References
- https://github.com/madpsy/ka9q_ubersdr/commit/6aa858da1c030cae11b94c7d6c72322adb9ec60d
- https://github.com/madpsy/ka9q_ubersdr/pull/114
Get alerted when CVE-2026-97723 or the next vulnerability affects your stack