What’s Vulnerable › Vulnerabilities
CVE-2026-97730
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-09-30
- Weakness: CWE-24
Description
In Netgate pfSense Plus before 26.07 and pfSense CE before 2.9.0, a Local File Inclusion (LFI) vulnerability in the Dashboard (index.php) widget sequence data handling allows an authenticated attacker to execute arbitrary PHP code. To exploit this, an attacker with privileges to modify Dashboard settings and write arbitrary files to the pfSense firewall system (e.g., /tmp/test.widget.php) can submit a crafted widget sequence value containing a path traversal payload (e.g., ../../../../../../../../../../../tmp/test). The Dashboard will subsequently read and execute the arbitrary PHP file as if it were a standard widget.
Affected products
- Netgate pfSense CE: before 2.9.0 — fixed in 2.9.0
- Netgate pfSense Plus: before 26.07 — fixed in 26.07
How to fix
Upgrade to a fixed version: Netgate pfSense CE 2.9.0; Netgate pfSense Plus 26.07. Check the vendor advisory for mitigations.
References
- https://docs.netgate.com/downloads/pfSense-SA-26_18.webgui.asc
- https://docs.netgate.com/pfsense/en/latest/install/upgrade-guide.html
- https://redmine.pfsense.org/attachments/7146
- https://redmine.pfsense.org/issues/16947
Get alerted when CVE-2026-97730 or the next vulnerability affects your stack