What’s Vulnerable › Vulnerabilities
CVE-2026-9800: Keycloak-policy-enforcer: keycloak policy enforcer: authorization bypass via incorrect uri comparison
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-20
- Weakness: CWE-1025
Description
A flaw was found in Keycloak Policy Enforcer. This vulnerability allows any authenticated user to bypass all authorization policies, including role, scope, and User-Managed Access (UMA) permission checks. By including the configured access-denied page path within a request URL, either as a path segment or a query parameter, an attacker can gain unauthorized access to protected resources.
Affected products
- Red Hat build of Keycloak 26.4: from 26.4 before 26.4.13; from 26.6 through 26.6.4 — fixed in 26.4.13
How to fix
Upgrade to a fixed version: Red Hat build of Keycloak 26.4 26.4.13. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:30049
- https://access.redhat.com/errata/RHSA-2026:30050
- https://access.redhat.com/errata/RHSA-2026:30083
- https://access.redhat.com/errata/RHSA-2026:30084
- https://access.redhat.com/errata/RHSA-2026:36002
- https://access.redhat.com/errata/RHSA-2026:36013
- https://access.redhat.com/errata/RHSA-2026:50846
- https://access.redhat.com/errata/RHSA-2026:50847
- https://access.redhat.com/security/cve/CVE-2026-9800
- https://bugzilla.redhat.com/show_bug.cgi?id=2482472
- https://access.redhat.com/errata/RHSA-2026:30049
- https://access.redhat.com/errata/RHSA-2026:30050
Get alerted when CVE-2026-9800 or the next vulnerability affects your stack