What’s Vulnerable › Vulnerabilities
CVE-2026-98114: ksmbd: propagate DACL parsing errors
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-10-28
- Weakness: CWE-252
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: propagate DACL parsing errors parse_dacl() silently accepts truncated ACEs and allocation failures, allowing set_info_sec() to continue with an incomplete ACL conversion. Return parsing and allocation errors to parse_sec_desc() so malformed security descriptors are rejected before inode attributes or ACL xattrs are updated.
Affected products
- Linux kernel: from 5.15 before 6.6.160; from 6.7 before 6.12.111; from 6.13 before 6.18.53; from 6.19 before 7.2.7; 7.3-rc1 — fixed in 6.6.160, 6.12.111, 6.18.53, 7.2.7
- Linux kernel: 5.15 — fixed in 7.3
How to fix
Upgrade to a fixed version: Linux kernel 6.6.160, 6.12.111, 6.18.53, 7.2.7; Linux kernel 7.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/37952f03d5171eb3a33b2abc2cf6e456d69ff4a1
- https://git.kernel.org/stable/c/461f10a5297e85b7c1cd21838922f2e57b934d2d
- https://git.kernel.org/stable/c/99ae165acf633b13df34105815110fec332a2cdc
- https://git.kernel.org/stable/c/a04dac1f2cffe9533f4260f0659297d805e69194
- https://git.kernel.org/stable/c/c61dc7b1b4a3234b4aa3965502908a292238805c
Get alerted when CVE-2026-98114 or the next vulnerability affects your stack