What’s Vulnerable › Vulnerabilities
CVE-2026-98142: drm/cirrus-qemu: Validate BAR0 size during probe
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-10-27
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: drm/cirrus-qemu: Validate BAR0 size during probe The `cirrus-qemu` driver relies on `CIRRUS_VRAM_SIZE` (4 MB) to validate framebuffer sizes. However, during PCI probe, the driver mapped BAR0 without verifying that its size matches `CIRRUS_VRAM_SIZE`. If a PCI device with a BAR0 smaller than 4 MB is bound to the driver, the mapped VRAM will be smaller than expected. Because validation checks assume 4 MB VRAM, framebuffers larger than the mapped memory can be created. When the display plane is updated (e.g. during release), `cirrus_primary_plane_helper_atomic_update()` copies the framebuffer to VRAM using `drm_fb_memcpy()`. Writing past the end of the mapped I/O memory causes a supervisor write page fault: BUG: unable to handle page fault for address: ffffc9000389c000 ... RIP: 0010:memcpy_toio+0x7c/0xe0 arch/x86/lib/iomem.c:110 ... Call Trace: <TASK> iosys_map_memcpy_to include/linux/iosys-map.h:285 [inline] drm_fb_memcpy+0x325/0x5d0 drivers/gpu/drm/drm_format_helper.c:442 cirrus_primary_plane_helper_atomic_update+0x98a/0xb00 drivers/gpu/drm/tiny/cirrus-qemu.c:358 drm_atomic_helper_commit_planes+0x626/0xea0 drivers/gpu/drm/drm_atomic_helper.c:3038 drm_atomic_helper_commit_tail+0x60/0x510 drivers/gpu/drm/drm_atomic_helper.c:1989 commit_tail+0x2b1/0x3c0 drivers/gpu/drm/drm_atomic_helper.c:2074 drm_atomic_helper_commit+0xa77/0xb10 drivers/gpu/drm/drm_atomic_helper.c:2312 Fix this by validating in `cirrus_pci_probe()` that the PCI BAR0 resource is not less than `CIRRUS_VRAM_SIZE`, returning `-ENODEV` if it is less.
Affected products
- Linux kernel: from 5.2 before 6.6.158; from 6.7 before 6.12.111; from 6.13 before 6.18.53; from 6.19 before 7.2.7; 7.3-rc1 — fixed in 6.6.158, 6.12.111, 6.18.53, 7.2.7
- Linux kernel: 5.2 — fixed in 7.3
How to fix
Upgrade to a fixed version: Linux kernel 6.6.158, 6.12.111, 6.18.53, 7.2.7; Linux kernel 7.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0b5084a1f070ad1fc34e11945644ae034bbc774c
- https://git.kernel.org/stable/c/144f51cd0ccc3ad47a6099917b7bb535611fb18f
- https://git.kernel.org/stable/c/26bd90c886218f36c9adeab206b0e27b4384e2f6
- https://git.kernel.org/stable/c/2a0e7bcff3fa63e7309d2b39e18af59eb8ef2b6e
- https://git.kernel.org/stable/c/92312d333bf700798f92f30406c721bce87506f3
Get alerted when CVE-2026-98142 or the next vulnerability affects your stack