What’s Vulnerable › Vulnerabilities

CVE-2026-9816: Insufficient server-side validation of board member role fields permits privilege escalation

Description

Mattermost versions 11.7.x <= 11.7.6, 10.11.x <= 10.11.21, 11.8.x <= 11.8.3 fail to validate BoardMember.Scheme* fields server-side on insert and archive-import paths which allows a board editor or non-guest team member to grant board admin to arbitrary users via POST /api/v2/boards/{boardID}/members and POST /api/v2/teams/{teamID}/archive/import.. Mattermost Advisory ID: MMSA-2026-00685

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.22, 11.7.7, 11.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-9816 or the next vulnerability affects your stack