What’s Vulnerable › Vulnerabilities
CVE-2026-98684: smb: client: flush and commit data before querying allocated ranges
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: smb: client: flush and commit data before querying allocated ranges The mode 0 / FALLOC_FL_KEEP_SIZE fallocate emulation for small interior ranges in smb3_simple_fallocate_range() issues FSCTL_QUERY_ALLOCATED_RANGES and zero-fills any sub-range the server reports as an unallocated hole, to force block allocation without changing file contents. This is unsafe against Windows servers. Per the Win32 documentation, FSCTL_QUERY_ALLOCATED_RANGES only reports ranges that *may* contain nonzero data and is explicitly not coherent with recently written data: "a call to FSCTL_QUERY_ALLOCATED_RANGES [after writing to a network file] would not necessarily return a correct list of allocated regions. To ensure coherency [...] flush the data to the file" fsx (generic/363) reproduces the resulting corruption against Windows Server 2022: a range is written, an uncached read returns the data, yet the next FSCTL_QUERY_ALLOCATED_RANGES on that range reports it as a whole hole, so the emulation overwrites live data with zeroes. A network trace confirmed the WRITE, the READ returning data and the query returning an empty range list within microseconds. Samba does not exhibit this; its query is coherent with the written data. Write back the dirty pages, drain any outstanding I/O and issue an SMB2 FLUSH to force the server to commit the data before querying the allocated ranges, so the query reflects the data actually present. With this, generic/363 passes against both Windows Server 2022 and Samba over 100000 fsx operations.
Affected products
- Linux kernel: from 5.10.50 before 5.11; from 5.12.17 before 5.13; from 5.13.2 before 5.14; 5.14 — fixed in 5.11, 5.13, 5.14, 7.3
How to fix
Upgrade to a fixed version: Linux kernel 5.11, 5.13, 5.14, 7.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/aa994489bd835547c191827acc460192e147032d
- https://git.kernel.org/stable/c/bf84e44ff0ed802778eafd7ecb623635379cb506
- https://git.kernel.org/stable/c/f82242fe3109a3ef72f429540b5bdde08fbfb0e4
Get alerted when CVE-2026-98684 or the next vulnerability affects your stack