What’s Vulnerable › Vulnerabilities
CVE-2026-98839: vt: selection: Fix unsigned underflow and slab-out-of-bounds read in paste_selection()
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-18 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: vt: selection: Fix unsigned underflow and slab-out-of-bounds read in paste_selection() In paste_selection(), the loop copies min_t(unsigned int, vc_sel.buf_len - pasted,tty->receive_room) bytes per iteration into tty_ldisc_receive_buf() and increments pasted += count. Because the selection mutex (vc_sel.lock) is dropped inside the loop Whenever the line discipline buffer fills up and paste_selection() sleeps on tty->write_wait, a concurrent TIOCLINUX (TIOCL_SETSEL) ioctl can replace vc_sel.buffer with a shorter selection and reduce vc_sel.buf_len below pasted. When paste_selection() resumes, vc_sel.buf_len - pasted underflows as an unsigned integer to a large positive value, causing tty_ldisc_receive_buf(ld, vc_sel.buffer + pasted, NULL, count) to read up to 4094 bytes out-of-bounds past the newly allocated vc_sel.buffer. Fix this by terminating the loop when pasted >= vc_sel.buf_len. Kernel stack trace (Linux 7.3.0-rc3): ================================================================== BUG: KASAN: slab-out-of-bounds in n_tty_receive_buf_common+0xa01/0x1650 Read of size 4094 at addr ffff888101c58010 by task kworker/u17:1/65 Workqueue: events_unbound flush_to_ldisc Call Trace: <TASK> dump_stack_lvl+0x70/0xa0 print_report+0x153/0x4c6 kasan_report+0xf1/0x120 kasan_check_range+0x11c/0x200 __asan_memcpy+0x29/0x70 n_tty_receive_buf_common+0xa01/0x1650 tty_ldisc_receive_buf+0x66/0x110 tty_port_default_receive_buf+0x6b/0xb0 flush_to_ldisc+0x1b4/0x410 process_one_work+0x6ff/0x1110 worker_thread+0x4a8/0xb70 kthread+0x307/0x3e0 ret_from_fork+0x3ed/0x680 </TASK> ==================================================================
Affected products
- Linux kernel: from 3.16.83 before 3.17; from 4.4.216 before 4.5; from 4.9.216 before 4.10; from 4.14.173 before 4.15; from 4.19.109 before 4.20; from 5.4.25 before 5.5 — fixed in 3.17, 4.10, 4.15, 4.20, 4.5, 5.5
How to fix
Upgrade to a fixed version: Linux kernel 3.17, 4.10, 4.15, 4.20. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/037d7e3ca5c593092f4b0d471eb869a85cbddde0
- https://git.kernel.org/stable/c/39495ef5d6f8019e62d65807f217a7ca8232727a
- https://git.kernel.org/stable/c/619c6d7dd76fff15a9714fbf02ce299b737f01a2
Get alerted when CVE-2026-98839 or the next vulnerability affects your stack