What’s Vulnerable › Vulnerabilities
CVE-2026-98902: md/raid5: let stripe batch bm_seq comparison wrap-safe
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-26
Description
In the Linux kernel, the following vulnerability has been resolved: md/raid5: let stripe batch bm_seq comparison wrap-safe Once the 32-bit seq wraps, a newer bm_seq can look smaller than old, so .. covert to wrap-safe calculate way.
Affected products
- Linux kernel: before 5.10.271; before 5.15.222; before 6.1.189; before 6.6.158; before 6.12.111; before 6.18.53 — fixed in 5.10.271, 5.15.222, 6.1.189, 6.12.111, 6.18.53, 6.6.158
How to fix
Upgrade to a fixed version: Linux kernel 5.10.271, 5.15.222, 6.1.189, 6.12.111. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/00e93faf4cea9e8802ac5dfee0952d84fc95c40f
- https://git.kernel.org/stable/c/2fdc51228d9a8cad2d727d5aef732cc66fc6d56e
- https://git.kernel.org/stable/c/628b14d0744bd5dfe176ea93559071cdcde14255
- https://git.kernel.org/stable/c/647c7289a3960118e249c0a53da6f1ebba1e47a3
- https://git.kernel.org/stable/c/c5c89e1a872a84019f674f5107111e6e6b7cc30f
- https://git.kernel.org/stable/c/cc8eb1715673de850f14376782151f68f73ae3ce
- https://git.kernel.org/stable/c/ffdd3aee932fc293456678f6b0200ffe9bf12a6d
Get alerted when CVE-2026-98902 or the next vulnerability affects your stack