What’s Vulnerable › Vulnerabilities
CVE-2026-98955: flow_dissector: avoid u16 truncation of skb->len when computing thoff
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: flow_dissector: avoid u16 truncation of skb->len when computing thoff __skb_flow_dissect() computes key_control->thoff using: key_control->thoff = min_t(u16, nhoff, skb ? skb->len : hlen); min_t(u16, ...) casts both arguments to u16 before comparing them. Whenever skb->len (or hlen) modulo 65536 is smaller than nhoff, the truncated length wins and thoff is set to a bogus small value, even when the dissection succeeded. For example, an IPv4/TCP frame with skb->len == 65540 and nhoff == 34 gets thoff == 4, so callers such as skb_probe_transport_header() point the transport header inside the Ethernet header. Such skbs are not exotic: - At the time of commit d0c081b49137 ("flow_dissector: properly cap thoff field"), AF_PACKET with PACKET_VNET_HDR could already build GSO skbs larger than 64KB (MTU checks are skipped for GSO, and alloc_skb_with_frags() accepted up to MAX_SKB_FRAGS (17) order-0 pages on top of the linear part). - BIG TCP now makes skbs larger than 64KB common. - The following patch makes tun_get_user() dissect IFF_TAP frames before eth_type_trans() pulls the Ethernet header, so a GSO frame carrying a 65522..65535 byte L3 packet will be dissected with skb->len in [65536, 65549]. Compare as u32 instead. If the resulting offset cannot be represented in the u16 key_control->thoff, cap it to U16_MAX and report the dissection as failed rather than silently returning a wrong transport offset. thoff is still set on failure, as some callers (such as eth_get_headlen()) use it regardless of the return value.
Affected products
- Linux: from 4.4.114 before 4.5; from 4.9.79 before 4.10; from 4.14.16 before 4.15 — fixed in 4.5, 4.10, 4.15
How to fix
Upgrade to a fixed version: Linux 4.5, 4.10, 4.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2c2f82b696c5e877f60ea77b7784e906a5e63014
- https://git.kernel.org/stable/c/3f6000fdf8a57b9786669869af8a3e050b541bf3
- https://git.kernel.org/stable/c/50d0cd575cab763f833d6ac6eb6550b23a0b3dae
- https://git.kernel.org/stable/c/52efce4755a4b8b82039caa773645ffc80b25362
- https://git.kernel.org/stable/c/9993e6a0ac1b5b3101ffba702cacb9f42b9909d8
- https://git.kernel.org/stable/c/99bda1ecbd56905f8bd934b9cdccd3bd251192b1
- https://git.kernel.org/stable/c/d44e66f5dd99319a32e378b610af7fcf78da985a
- https://git.kernel.org/stable/c/d9e08836d06c84abb18470c94b12b131eaccdc7d
Get alerted when CVE-2026-98955 or the next vulnerability affects your stack