What’s Vulnerable › Products
buildwps PPWP – Password Protect Pages vulnerabilities
9 known vulnerabilities, 0 confirmed exploited in the wild (CISA KEV), 7 published in the last 12 months.
Check whether your buildwps PPWP – Password Protect Pages version is affected
Latest buildwps PPWP – Password Protect Pages vulnerabilities
- CVE-2025-9878 — Password Protect WordPress Lite <= 1.9.21 - Authenticated (Contributor+) Stored Cross-Site Scripting (CVSS 6.4)
- CVE-2026-0551 — PPWP – Password Protect Pages <= 1.9.18 - Authenticated (Contributor+) PHP Object Injection via post_protection_roles (CVSS 8.8)
- CVE-2025-11729 — PPWP: Password Protect Pages, Posts & Full or Partial Content <= 1.9.15 - Improper Authorization To Authenticated (Contributor+) Master Password Exposure (CVSS 4.3)
- CVE-2025-10005 — Password Protect WordPress Lite <= 1.9.20 - Insecure Direct Object Reference to Authenticated (Contributor+) Password Protected Post Password Update (CVSS 4.3)
- CVE-2026-3639 — PPWP – Password Protect Pages <= 1.9.21 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes (CVSS 6.4)
- CVE-2025-5998 — PPWP < 1.9.11 - Subscriber+ Access Bypass via REST API (CVSS 6.5)
- CVE-2024-11280 — PPWP – Password Protect Pages <= 1.9.5 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure (CVSS 5.3)
- CVE-2024-0620 — PPWP – Password Protect Pages <= 1.8.9 - Protection Mechanism Bypass (CVSS 5.3)
- CVE-2022-4626 — PPWP – WordPress Password Protect Page < 1.8.6 - Contributor+ Stored XSS in Shortcode (CVSS 5.4)