What’s Vulnerable › Vulnerabilities
CVE-2025-5998: PPWP < 1.9.11 - Subscriber+ Access Bypass via REST API
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-14 · updated 2026-06-17
Description
The PPWP – Password Protect Pages WordPress plugin before version 1.9.11 allows to put the site content behind a password authorization, however users with subscriber or greater roles can view content via the REST API.
Affected products
- buildwps PPWP – Password Protect Pages: before 1.9.11 — fixed in 1.9.11
How to fix
Upgrade to a fixed version: buildwps PPWP – Password Protect Pages 1.9.11. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/17bad181-6cea-445e-b91c-22415d90743e/
- https://wpscan.com/vulnerability/17bad181-6cea-445e-b91c-22415d90743e/
Get alerted when CVE-2025-5998 or the next vulnerability affects your stack