What’s Vulnerable › Products
ShortPixel Adaptive Images vulnerabilities
11 known vulnerabilities, 0 confirmed exploited in the wild (CISA KEV), 5 published in the last 12 months.
Check whether your ShortPixel Adaptive Images version is affected
Latest ShortPixel Adaptive Images vulnerabilities
- CVE-2026-15345 — ShortPixel Adaptive Images <= 3.11.5 - Missing Authorization to Authenticated (Subscriber+) Third-Party Plugin Option Modification via 'causer' Parameter (CVSS 4.3)
- CVE-2026-57342 — WordPress ShortPixel Adaptive Images plugin <= 3.11.3 - Cross Site Scripting (XSS) vulnerability (CVSS 6.5)
- CVE-2026-56066 — WordPress ShortPixel Adaptive Images plugin <= 3.11.4 - Arbitrary File Deletion vulnerability (CVSS 5.8)
- CVE-2025-6626 — ShortPixel Adaptive Images – WebP, AVIF, CDN, Image Optimization <= 3.10.4 - Authenticated (Administrator+) Stored Cross-Site Scripting via API URL (CVSS 4.4)
- CVE-2025-30853 — WordPress ShortPixel Adaptive Images plugin <= 3.10.0 - Broken Authentication vulnerability (CVSS 5.4)
- CVE-2024-4689 — WordPress ShortPixel Adaptive Images plugin <= 3.8.3 - Cross Site Request Forgery (CSRF) vulnerability (CVSS 4.3)
- CVE-2024-35172 — WordPress ShortPixel Adaptive Images plugin <= 3.8.3 - Server Side Request Forgery (SSRF) vulnerability (CVSS 4.4)
- CVE-2024-31230 — WordPress ShortPixel Adaptive Images plugin <= 3.8.2 - Broken Access Control vulnerability (CVSS 5.3)
- CVE-2023-32512 — WordPress ShortPixel Adaptive Images Plugin <= 3.7.1 is vulnerable to Cross Site Request Forgery (CSRF) (CVSS 8.8)
- CVE-2023-0334 — ShortPixel Adaptive Images < 3.6.3 - Reflected XSS (CVSS 6.1)
- CVE-2022-29417 — WordPress ShortPixel Adaptive Images plugin <= 3.3.1 - Subscriber+ Plugin Settings Update vulnerability (CVSS 4.3)