What’s Vulnerable › Vulnerabilities
CVE-2023-0334: ShortPixel Adaptive Images < 3.6.3 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-27 · updated 2026-06-17
Description
The ShortPixel Adaptive Images WordPress plugin before 3.6.3 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against any high privilege users such as admin
Affected products
- ShortPixel Adaptive Images: before 3.6.3 — fixed in 3.6.3
How to fix
Upgrade to a fixed version: ShortPixel Adaptive Images 3.6.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b027a8db-0fd6-444d-b14a-0ae58f04f931
- https://wpscan.com/vulnerability/b027a8db-0fd6-444d-b14a-0ae58f04f931
Get alerted when CVE-2023-0334 or the next vulnerability affects your stack