What’s Vulnerable › Vulnerabilities
CVE-2015-1784
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-07 · updated 2026-06-17
- Weakness: CWE-434
Description
In nextgen-galery wordpress plugin before 2.0.77.3 there are two vulnerabilities which can allow an attacker to gain full access over the web application. The vulnerabilities lie in how the application validates user uploaded files and lack of security measures preventing unwanted HTTP requests.
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 2.0.77.3 — fixed in 2.0.77.3
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 2.0.77.3. Check the vendor advisory for mitigations.
References
- https://blog.nettitude.com/uk/crsf-and-unsafe-arbitrary-file-upload-in-nextgen-gallery-plugin-for-wordpress
- https://wpscan.com/vulnerability/c894727a-b779-4583-a860-13c2c27275d4
- https://blog.nettitude.com/uk/crsf-and-unsafe-arbitrary-file-upload-in-nextgen-gallery-plugin-for-wordpress
- https://wpscan.com/vulnerability/c894727a-b779-4583-a860-13c2c27275d4
Get alerted when CVE-2015-1784 or the next vulnerability affects your stack