What’s Vulnerable › Vulnerabilities
CVE-2015-9537
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The NextGEN Gallery plugin before 2.1.10 for WordPress has multiple XSS issues involving thumbnail_width, thumbnail_height, thumbwidth, thumbheight, wmXpos, and wmYpos, and template.
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 2.1.10 — fixed in 2.1.10
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 2.1.10. Check the vendor advisory for mitigations.
References
- https://cybersecurityworks.com/zerodays/cve-2015-9537-nextgen.html
- https://github.com/cybersecurityworks/Disclosed/issues/1
- https://wordpress.org/plugins/nextgen-gallery/#developers
- https://www.openwall.com/lists/oss-security/2015/10/27/4
- https://cybersecurityworks.com/zerodays/cve-2015-9537-nextgen.html
- https://github.com/cybersecurityworks/Disclosed/issues/1
- https://wordpress.org/plugins/nextgen-gallery/#developers
- https://www.openwall.com/lists/oss-security/2015/10/27/4
Get alerted when CVE-2015-9537 or the next vulnerability affects your stack