What’s Vulnerable › Vulnerabilities
CVE-2016-6565: The Imagely NextGen Gallery plugin for Wordpress prior to version 2.1.57 may execute code from an uploaded malicious file
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-13 · updated 2026-06-17
- Weakness: CWE-98
Description
The Imagely NextGen Gallery plugin for Wordpress prior to version 2.1.57 does not properly validate user input in the cssfile parameter of a HTTP POST request, which may allow an authenticated user to read arbitrary files from the server, or execute arbitrary code on the server in some circumstances (dependent on server configuration).
Affected products
- Photo Gallery, Sliders, Proofing and Themes: before 2.1.57 — fixed in 2.1.57
How to fix
Upgrade to a fixed version: Photo Gallery, Sliders, Proofing and Themes 2.1.57. Check the vendor advisory for mitigations.
References
- https://www.kb.cert.org/vuls/id/346175
- https://www.securityfocus.com/bid/94356/
- https://www.kb.cert.org/vuls/id/346175
- https://www.securityfocus.com/bid/94356/
Get alerted when CVE-2016-6565 or the next vulnerability affects your stack