What’s Vulnerable › Vulnerabilities
CVE-2019-10692
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 77.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-02 · updated 2026-06-17
- Weakness: CWE-89
Description
In the wp-google-maps plugin before 7.11.18 for WordPress, includes/class.rest-api.php in the REST API does not sanitize field names before a SELECT statement.
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 7.11.18 — fixed in 7.11.18
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 7.11.18. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/159640/WordPress-Rest-Google-Maps-SQL-Injection.html
- http://www.rapid7.com/db/modules/auxiliary/admin/http/wp_google_maps_sqli
- https://plugins.trac.wordpress.org/changeset?old_path=%2Fwp-google-maps&old=2061433&new_path=%2Fwp-google-maps&new=2061434&sfp_email=&sfph_mail=#file755
- https://wordpress.org/plugins/wp-google-maps/#developers
- http://packetstormsecurity.com/files/159640/WordPress-Rest-Google-Maps-SQL-Injection.html
- http://www.rapid7.com/db/modules/auxiliary/admin/http/wp_google_maps_sqli
- https://plugins.trac.wordpress.org/changeset?old_path=%2Fwp-google-maps&old=2061433&new_path=%2Fwp-google-maps&new=2061434&sfp_email=&sfph_mail=#file755
- https://wordpress.org/plugins/wp-google-maps/#developers
Get alerted when CVE-2019-10692 or the next vulnerability affects your stack