What’s Vulnerable › Products
wpgmaps WP Go Maps (formerly WP Google Maps) vulnerabilities
23 known vulnerabilities, 0 confirmed exploited in the wild (CISA KEV), 8 published in the last 12 months.
Check whether your wpgmaps WP Go Maps (formerly WP Google Maps) version is affected
Latest wpgmaps WP Go Maps (formerly WP Google Maps) vulnerabilities
- CVE-2026-84780 — WordPress WP Go Maps plugin <= 10.1.08 - Denial of Service Attack vulnerability (CVSS 5.3)
- CVE-2026-25466 — WordPress WP Go Maps plugin <= 10.1.04 - Broken Access Control vulnerability (CVSS 5.3)
- CVE-2026-4268 — WP Go Maps (formerly WP Google Maps) <= 10.0.05 - Missing Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting via admin_post_wpgmza_save_settings (CVSS 6.4)
- CVE-2026-0593 — WP Go Maps (formerly WP Google Maps) <= 10.0.04 - Missing Authorization to Authenticated (Subscriber+) Map Engine Setting Modification (CVSS 5.3)
- CVE-2025-11307 — WP Google Maps < 9.0.48 - Unauthenticated Stored XSS (CVSS 8.8)
- CVE-2025-11703 — WP Go Maps (formerly WP Google Maps) <= 9.0.48 - Unauthenticated Cache Poisoning (CVSS 5.3)
- CVE-2025-11166 — WP Go Maps (formerly WP Google Maps) <= 9.0.46 - Cross-Site Request Forgery to Plugin Settings Update (CVSS 5.4)
- CVE-2025-24742 — WordPress WP Google Maps plugin <= 9.0.40 - Cross Site Request Forgery (CSRF) vulnerability (CVSS 8.8)
- CVE-2024-5994 — WP Go Maps (formerly WP Google Maps) <= 9.0.38 - Authenticated (Contributor+) Stored Cross-Site Scripting (CVSS 5.4)
- CVE-2024-3557 — WP Go Maps (formerly WP Google Maps) <= 9.0.36 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode (CVSS 5.4)
- CVE-2023-6777 — WP Go Maps (formerly WP Google Maps) <= 9.0.34 - Information Exposure to Potential Denial of Service (CVSS 6.5)
- CVE-2024-29931 — WordPress WP Go Maps plugin <= 9.0.29 - Reflected Cross Site Scripting (XSS) vulnerability (CVSS 6.1)
- CVE-2024-1582 — WP Go Maps (formerly WP Google Maps) <= 9.0.32 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode (CVSS 5.4)
- CVE-2023-4839 — WP Go Maps <= 9.0.32 - Authenticated (Administrator+) Stored Cross-Site Scripting (CVSS 4.8)
- CVE-2023-6627 — WP Go Maps < 9.0.28 - Unauthenticated Stored XSS (CVSS 6.1)
- CVE-2022-47595 — WordPress WP Google Maps Plugin <= 9.0.15 is vulnerable to Path Traversal (CVSS 6.5)
- CVE-2021-36871 — WordPress WP Google Maps Pro premium plugin <= 8.1.11 - Multiple Authenticated Persistent XSS vulnerabilities (CVSS 5.4)
- CVE-2021-36870 — WordPress WP Google Maps plugin <= 8.1.12 - Multiple Authenticated Persistent XSS vulnerabilities (CVSS 5.4)
- CVE-2021-24383 — WP Google Maps < 8.1.12 - Authenticated Stored Cross-Site Scripting (XSS) (CVSS 5.4)
- CVE-2019-14792 — (CVSS 5.4)
- CVE-2019-10692 — (CVSS 9.8)
- CVE-2019-9912 — (CVSS 6.1)
- CVE-2014-7182 — (CVSS 4.3)