What’s Vulnerable › Vulnerabilities
CVE-2025-11307: WP Google Maps < 9.0.48 - Unauthenticated Stored XSS
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-11 · updated 2026-10-19
Description
The WP Go Maps (formerly WP Google Maps) WordPress plugin before 9.0.48 does not sanitize user input provided via an AJAX action, allowing unauthenticated users to store XSS payloads which are later retrieved from another AJAX call and output unescaped.
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 9.0.48 — fixed in 9.0.48
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 9.0.48. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11307 or the next vulnerability affects your stack