What’s Vulnerable › Vulnerabilities
CVE-2019-9912
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The wp-google-maps plugin before 7.10.43 for WordPress has XSS via the wp-admin/admin.php PATH_INFO.
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 7.10.43 — fixed in 7.10.43
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 7.10.43. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2019/Mar/41
- https://lists.openwall.net/full-disclosure/2019/02/05/13
- https://security-consulting.icu/blog/2019/02/wordpress-wpgooglemaps-xss/
- http://seclists.org/fulldisclosure/2019/Mar/41
- https://lists.openwall.net/full-disclosure/2019/02/05/13
- https://security-consulting.icu/blog/2019/02/wordpress-wpgooglemaps-xss/
Get alerted when CVE-2019-9912 or the next vulnerability affects your stack