What’s Vulnerable › Vulnerabilities
CVE-2024-5994: WP Go Maps (formerly WP Google Maps) <= 9.0.38 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Go Maps (formerly WP Google Maps) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Custom JS option in versions up to, and including, 9.0.38. This makes it possible for authenticated attackers that have been explicitly granted permissions by an administrator, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Version 9.0.39 adds a caution to make administrators aware of the possibility for abuse if permissions are granted to lower-level users.
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 9.0.39 — fixed in 9.0.39
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 9.0.39. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-google-maps/trunk/html/atlas-novus/settings-page.html.php#L442
- https://plugins.trac.wordpress.org/browser/wp-google-maps/trunk/html/settings-page.html.php#L538
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dd0597d2-07ba-4fb4-bf73-95770f8c3d6b?source=cve
- https://plugins.trac.wordpress.org/browser/wp-google-maps/trunk/html/atlas-novus/settings-page.html.php#L442
- https://plugins.trac.wordpress.org/browser/wp-google-maps/trunk/html/settings-page.html.php#L538
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dd0597d2-07ba-4fb4-bf73-95770f8c3d6b?source=cve
Get alerted when CVE-2024-5994 or the next vulnerability affects your stack