What’s Vulnerable › Vulnerabilities
CVE-2023-6627: WP Go Maps < 9.0.28 - Unauthenticated Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Go Maps (formerly WP Google Maps) WordPress plugin before 9.0.28 does not properly protect most of its REST API routes, which attackers can abuse to store malicious HTML/Javascript on the site.
Affected products
- wpgmaps WP Go Maps (formerly WP Google Maps): before 9.0.28 — fixed in 9.0.28
How to fix
Upgrade to a fixed version: wpgmaps WP Go Maps (formerly WP Google Maps) 9.0.28. Check the vendor advisory for mitigations.
References
- https://wpscan.com/blog/stored-xss-fixed-in-wp-go-maps-9-0-28/
- https://wpscan.com/vulnerability/f5687d0e-98ca-4449-98d6-7170c97c8f54
- https://wpscan.com/blog/stored-xss-fixed-in-wp-go-maps-9-0-28/
- https://wpscan.com/vulnerability/f5687d0e-98ca-4449-98d6-7170c97c8f54
Get alerted when CVE-2023-6627 or the next vulnerability affects your stack